• Welcome to PlumbersForums.net - The international free plumbing advice forum. Professional plumbers sharing advice with fellow plumbers and DIY alike. Register for free today! - Checkout the Plumbing Advice forum and then our Plumbing Videos area which still needs populating.

From the United States of America? - Checkout our specific plumbing forum for you:USA Plumbing Forum

Discuss Worcester Bosch Danesmoor 20/25 Problem in the Oil and Solid Fuel Forum area at PlumbersForums.net

Reaction score
0
Is there anyone out there who has come across this problem.
Our boiler locked out so pressed the reset button and it seemed that all was fine. Red light went out and fan started etc. About an hour later noticed nothing seemed to be warming up. But motor was still running and no lockout. Called out service guy who replaced photocell. Same result, motor starts no ignition but motor continued to run.
So he replaced control box (Honeywell TF832.3) the replaced box had some heat damage at top right corner. Service man said faulty photocell could have damaged controller.
Tried again, same result. Service man checked ignition unit and replaced. Again he said there was evidence of heat damage.
This time boiler fired and ran, for just over an hour. No lockout but cold pipes. Service man came out again and replaced control box. Boiler fired and ran. This time for just over two hours.

Questions.
1. Why is the boiler not locking out and motor turning off when there is no flame? Honeywell data sheet and common sense suggest that a lock out should occur.
2. Has anyone come across this type of problem before and any suggestions?

Thanks Guys
 

Reply to Worcester Bosch Danesmoor 20/25 Problem in the Oil and Solid Fuel Forum area at PlumbersForums.net

New Posts Threads Members

Top