• Welcome to PlumbersForums.net - The international free plumbing advice forum. Professional plumbers sharing advice with fellow plumbers and DIY alike. Register for free today! - Checkout the Plumbing Advice forum and then our Plumbing Videos area which still needs populating.

Discuss Underfloor Heating Pump goes into a blocked error (Grundfos UPM3) in the Central Heating Forum area at PlumbersForums.net

Messages
4
Hi all!

Went to stick the underfloor heating on and the pump started making a weird noise and the first red LED and the last amber LED are on - which per instructions means that the pump is blocked and it is necessary to deblock the shaft. It has a deblocking screw in the centre of the control box so I push it down and turned it counter-clockwise multiple times and I can hear it turning so the shaft shouldn't be blocked. But when I turn the system back on it goes into the same error mode.
I even tried to give it a a few love taps with a rubber hammer - anything else I can do, besides calling the engineer to have a look?

The pump is also a new one having been installed back in March this year, so I doubt any sludge is in the pump yet.
Worth mentioning that this is the first time we have switched the heating on for at least 5 months.
 

Attachments

  • Screenshot 2021-10-09 at 10.59.43.png
    Screenshot 2021-10-09 at 10.59.43.png
    93.3 KB · Views: 0

Reply to Underfloor Heating Pump goes into a blocked error (Grundfos UPM3) in the Central Heating Forum area at PlumbersForums.net

Top