Discuss Nu-heat Blend valve not working on underfloor heating in the Plumbing Forum | Plumbing Advice area at PlumbersForums.net

Messages
54
Hi,

I have I blend valve from Nu-Heat ( they bought it from Reliance, as per attached spec). I have dismantled the valve now 3 times and replaced it with new components from Nu-Heat but the valve is not working properly.

The valve replacement seems very simple with 4 main components and some grease, but every time I replace the components and put on soak test the temperature goes up to the boiler temp of around 70 degrees. The underfloor heating floor design temp is 50 degrees max.

The initial valve worked for around 5 years but is stubbornly not functioning. While doing my soak test I turn the valve down to zero degrees ( or max screwed in ) and the temp still goes above 50 agrees gradually over 7 mins, I cannot tighten the screw valve anymore and would expect it to be locked shut at that level, even when I take the cap off the top and try and screw it further closed ( there is not more travel on the thread ).

I think my next step is to buy the whole valve and assembly together if this doesn't work.

Any ideas welcome? !!

Many thanks Matt
 

Attachments

    You don't have permission to view attachments. Attachments are hidden.

Reply to Nu-heat Blend valve not working on underfloor heating in the Plumbing Forum | Plumbing Advice area at PlumbersForums.net

Creating content since 2001. Untold Media.

Some Stats

Threads
98,775
Messages
1,073,088
Members
25,568
Latest member
FSTumi
Back
Top