Test4Less - PlumbersForums.net Sponsor
This official sponsor may provide discounts for members

Discuss Oil boiler not heating up in the Plumbing Forum | Plumbing Advice area at PlumbersForums.net

Any one had this problem oil boiler is running as normal but no flame at burner it’s a green star 18/25 external oil boiler
 
Plumbase Perks - Special offers for forum members
This official sponsor may provide discounts for members
Check for 50-53 volts AC on white and black wire for motor. If that's good pull out photocell and cover and try ignition sequence again, if it starts its reading false light and it must be eliminated. If that doesn't do it the cell could be faulty, ie thinking its seeing light, test ohms with cell covered and exposed to light to see what that says. Can confirm it's the cell by removing from control box and try ignition sequence again, if it's the cell it will start and go to lockout. If it still stays in pre purge test coil resistance, should be around 100 ohms, if that's ok test for continuity on coil leads from control box. If all that's failed then I would change box but you already said it's been changed.
 
Check for 50-53 volts AC on white and black wire for motor. If that's good pull out photocell and cover and try ignition sequence again, if it starts its reading false light and it must be eliminated. If that doesn't do it the cell could be faulty, ie thinking its seeing light, test ohms with cell covered and exposed to light to see what that says. Can confirm it's the cell by removing from control box and try ignition sequence again, if it's the cell it will start and go to lockout. If it still stays in pre purge test coil resistance, should be around 100 ohms, if that's ok test for continuity on coil leads from control box. If all that's failed then I would change box but you already said it's been changed.
Yes I have changed control box and photo cell and still continues to run as everthin is okay but there is no flame at burner ?
 
Is it staying in pre purge (motor and fan running) or going to lockout after safety time? Everything I said above is is to test why it is stuck in pre purge. If it goes to lockout then it's a fuel or ignition problem, each of which can be caused by a number of problems.
 
check for oil at pump also the coil on the pump. If the fan is running continuous but no fuel the coil will not let the fuel into the combustion chamber.
 

Reply to Oil boiler not heating up in the Plumbing Forum | Plumbing Advice area at PlumbersForums.net. Plumbing questions, answers, tips and tricks.

Plumbase - Special Offers and Perks on Plumbing Deals
This official sponsor may provide discounts for members
Plumbase - PlumbersForums.net Sponsor
Wetroom Store - PlumbersForums.net Sponsor
Plumbing Advice - Find Plumbers Jobs
uHeat Forum Sponsor - PlumbersForums.net
Test4Less PlumbersForums.net Sponsor
Bulk Workwear - Workwear Sponsor for Plumbers Forums
Corgi Direct - Plumbers Forums Sponsor
Power Shower Booster - Official PlumbersForums.net Sponsor

New Posts Threads Members

Bulk Workwear - Workmans Clothing and Protective Gear
This official sponsor may provide discounts for members
Top