From the United States of America? - Checkout our specific plumbing forum for you:USA Plumbing Forum

Discuss Help needed on central heating problem in the Plumbing Forum | Plumbing Advice area at PlumbersForums.net

Evening gents

I have a Worcester green star ri controlled by a Honeywell st9420c controller and wireless thermostat

All working fine this morning now when home from work I’m getting no heating. The light is on on the controller and the digital thermostat is showing the fire symbol but there’s no heating working at all

Hot water is heating up apparently fine and the boiler will periodically fire up and then stop again about 10 seconds later

Any ideas? Had a new grundfos pump and switch fitted 18 months ago

Thanks a lot in advance
 
Seem to be mate. Will double check
Post automatically merged:

Yep changed them and still the same
 
Last edited:

king of pipes

Esteemed
Plumber
Gas Engineer
Advent Win
Do you have a hot water cylinder and zone valves as below ? It may be a faulty head on the heating valve it may be possible to lock the head open its a common fault the motor may be burnt out or the linkage worn so not triggering the micro switch when it moved over . Kop
 

Reply to Help needed on central heating problem in the Plumbing Forum | Plumbing Advice area at PlumbersForums.net. Plumbing questions, answers, tips and tricks.

Plumbing and Plumbers

Plumbing Workwear

Shower Power Booster

Plumbase Spares - Plumbing Supplies and Spare Parts

Water Underfloor Heating

CORGI Direct for Plumbers

The Wetroom Store

Plumbase Spares

New Posts Threads Members

Top